آموزش مایکروسافت تری‌دی بیلدر/تمرین لوکوموتیو

ویکی‎کتاب، کتابخانهٔ آزاد
پرش به ناوبری پرش به جستجو
آشنایی تمرین لوکوموتیو خروجی کار
آموزش مایکروسافت تری‌دی بیلدر


پروژه لوکوموتیو[ویرایش]

از منوی Start ویندوز وارد Windows accessories شده و نرم‌افزار 3D Builder را باز کنید. یک پنجره باز می‌شود که چند چهارگوش درون آن وجود دارد. بر روی چهارگوش Open کلیک کنید سپس روی Load object کلیک کنید. به This PC (همان My computer در ویندوزهای قدیمی) بروید و سپس از پوشه 3D Objects فایل Train engine را باز کنید. در پیرامون موقعیت صفر میلیمتر در صحنه یک لوکوموتیو به همراه ۶ چرخ ظاهر می‌شود. از پالت گزینه مثلث تکی (Sticky selection) را انتخاب کنید. سپس بر روی لوکومتیو کلیک کنید. حواستان باشد که چرخ‌ها نباید در حالت انتخاب قرار داشته باشند. اگر شی دیگری غیر از لوکوموتیو انتخاب شده است کافی است بر روی آن کلیک کنید تا از انتخاب خارج شود. یک کادر مربوط به شی انتخاب شده در پایین صحنه دیده می‌شود که می‌توانید به کمک آن تغییراتی در شی ایجاد کنید. آیکن اول این مجموعه (Move) برای جایجایی است، آیکن دوم (Rotate) برای چرخاندن شی است و آیکن سوم (Scale) برای تغییر اندازه. پس از انتخاب لوکوموتیو بر روی آیکن Scale کلیک کنید. سه آیکن در ردیف پایین کادر قرار می‌گیرد. اگر آیکن دوم ردیف پایین mm است آن را به % تغییر دهید. در کنار علامت % یک عدد باید در کادر وارد کنید. این عدد را ۱۵۰ بگذارید و معنی آن این است که شی انتخاب شده ۱٫۵ برابر بزرگ خواهد شد. دوباره این عدد را به -۱۵۰ تغییر دهید. لوکوتیو هم ۱٫۵ برابر بزرگتر می‌شود و هم به سمت راست تغییر مسیر می‌دهد. از کادر تنظیمات شی، روی آیکن Move کلیک کنید. گیزموی ظاهر شده روی شی را در راستای محور y و به سمت بالا جابجا کنید. لوکوموتیو در موقعیت مناسب قرار می‌گیرد تا بتوانیم چرخ‌ها را در زیر آن قرار دهیم.

در صورت تمایل می‌توانید رنگ و بافت لوکوموتیو را تغییر دهید. برای این کار از منوی Paint گزینه Color را انتخاب کنید. از منوی آبشاری Selected یک رنگ انتخاب کنید و با کلیک روی Color رنگ خود را تأیید کنید. این کار را برای سایر اشیای صحنه نیز می‌توانید انجام دهید. لوکوموتیو را از حالت انتخاب خارج کرده و سه چرخ جلوی صحنه را انتخاب کنید. دقت کنید هر سه چرخ انتخاب شده باشند. از کادر تنظیم، بر روی آیکن Rotate کلیک کنید و در پایین آن در کنار deg عدد ۹۰ را تایپ کنید. چرخ‌ها در موقعیت ۹۰ درجه قرار می‌گیرند آن طور که باید باشند. حالا باید چرخ‌ها را تک تک در زیر لوکوموتیو در جای خود قرار دهید. برای این کار از آیکن Move استفاده می‌کنید و برای درگ گیزموها در سه راستا چرخ را به جایگاه مناسب انتقال می‌دهید.

این پروژه تمام شده و شما یک لوکوموتیو زیبا مدلسازی کرده‌اید. در صورتی که علاقه داشته باشید می‌توانید عناصر دیگری را به صحنه اضافه کنید. یکی از قابلیت‌های تری‌دی بیلدر نورپردازی صحنه است. برای افزودن یا حذف نور از منوی View بر روی آیکن لامپ (Shadows) کلیک کنید. برای بررسی لوکوموتیو از تمام زوایا می‌توانید صحنه را بچرخانید.

ویرایش اشیا[ویرایش]

دو منوی Object و Edit برای ویرایش اشیا در تری‌دی بیلدر هستند. این کار پس از انتخاب اشیا انجام می‌گیرد، هر شی انتخاب شده با یک نوار آبی دور شی مشخص می‌شود. گزینه‌های Duplicate و Copy در منوی Object برای ایجاد یک شی همانند شی قبلی است. از منوی Edit می‌توانید جلوه‌هایی همچون Smooth (برای از بین بردن گوشه‌های تیز شی) و Extrude (برجسته کردن) به شی بدهید. هر جای کار را اشتباه کردید یا قصد آزمون و خطا دارید می‌توانید از دکمه‌های Undo و Redo استفاده کنید. این دو دکمه همیشه در بالای نرم‌افزار سمت راست وجود دارند. گاهی ممکن است نیاز باشد زوم کنید تا بهتر بتوانید با اشیا کار کنید. زوم کردن به همان روشی انجام می‌گیرد که در سایر نرم‌افزارهای ویرایش تصویر قبلا دیده‌اید. با چرخاندن غلطک ماوس صحنه دور و نزدیک می‌شود.

رنگ‌ها[ویرایش]

برای رنگ کردن شی پس از انتخاب رنگ روبروی Selected، بایستی شعاع نفوذ رنگ را تعیین کنید. برای این کار غلطک روبروی Coverage را جابجا کنید، هر چه به سمت راست بروید شعاع رنگ بیشتر شده و بخش‌های بیشتری از شی را فرا خواهد گرفت. پس از انتخاب رنگ و شعاع رنگ‌آمیزی، نشانگر ماوس را روی شی منتقل کرده و کلیک کنید. سپس روی تیک Color کلیک کنید.

رنگ‌ها بسیار زیاد هستند می‌توانید از رنگ‌های موجود در مربع‌ها یا رنگ‌هایی که قبلا استفاده کرده‌اید برای رنگ‌آمیزی اشیا استفاده کنید. همچنین می‌توانید با ترکیب رنگ‌های قبلی، رنگ جدید بسازید. یک گزینه دیگر این است که یک شی را به رنگ شی دیگری در صحنه درآورید و به عبارتی دو شی یا چند شی همرنگ داشته باشید. برای همرنگ کردن اشیا روی مربع روبروی Selected کلیک کرده، گزینه Eyedropper را انتخاب کنید. یک ابزار شبیه ماژیک انتخاب می‌شود ماوس را حرکت داده و به روی رنگ مورد نظر که در اشیا به کار رفته است بروید و کلیک کنید. سپس روی تیک Color کلیک کنید تا رنگ انتخابی شما تأیید شود. برای ایجاد رنگ جدید باید از روبروی Selected، گزینه More colors… را بزنید. سه پارامتر Hue، Saturation و Brightness را تنظیم کنید و برای رنگ جدید یک اسم انتخاب کنید.