آموزش کار با تری‌دی مکس/محیط کاربری

ویکی‎کتاب، کتابخانهٔ آزاد
پرش به ناوبری پرش به جستجو

محیط کاربری تری‌دی مکس پنجره‌ای است شامل دیدگاه‌ها (viewports)، نوار ابزار (Toolbar)، منوها (Main menu) و پانل‌ها (Panels).

منوها[ویرایش]

نوار منو درست در زیر نوار عنوان برنامه قرار دارد که تمام فرمان ها و عملیات قابل اجرا در 3D max در این منوها موجود است.

ما ابتدا منوهایی را توضیح می دهیم که در پانل ها گزینه های آنها موجود نیست و تنها راه دست پیدا کردن آنها از طریق این منوها یا از طریق کلیدهای میان بر است پس ابتدا به آموزش منوهای Group و Edit و File می پردازیم.

البته این مرحله یک مقدار خسته کننده است ولی یادگیری آن جزء کار و قسمت جداناشدنی نرم افزار است.

منوی File[ویرایش]

این منو شامل فرمان‌های زیر می باشد:

فرمان New :

اجرای این فرمان سبب پاک شدن صحنه فعلی و جایگزینی صحنه جدید می شود که معادل کلیدهای میان‌بر Ctrl +N می باشد. زمانی که این گزینه را انتخاب نمایید قسمت Options نمایان می شود. گزینه اول اگر انتخاب شود هم اشیاء درون صحنه و هم چنین تنظیمات سلسله مراتبی آنها حفظ شده فقط کلیدهای متحرک سازی آن از بین می رود.

انتخاب گزینه دوم سبب از بین رفتن تنظیمات سلسله مراتبی و نیز کلیدهای متحرک سازی می شود ولی اشیاء درون صحنه هنوز وجود دارند.

انتخاب گزینه سوم باعث از بین رفتن تمام اشیاء و تنظیمات می شود.

فرمان Reset :

این فرمان تمان تنظیمات نرم افزار را به صورت پیش فرض تغییر می دهد.

فرمان Open :

به کمک این فرمان می توانید فایل های با پسوند (MAX) یا یک فایل کاراکتر (CHR) یا فایل رندر (VIZ) را باز کنید. فایل های (DRF) یک فایل صحنه از یک رندر VIZ است، این نوع فایل ها شباهت زیادی به فایلهای Max دارند اما توسط رندر شرکت AutoDesk رندر می شوند.

ObseleteFile :

هرگاه فایلی از نسخه های قبلی Max وارد نسخه جدید آن کنید این پنجره باز می شود که به شما می گوید این فایل برای نسخه پایین تر 3D maxاست ( فایلهای نسخه جدید در نسخه قدیم باز نمی شود).

فرمانOpen Recent :

این فرمان فهرستی از جدیدترین فایل ها که باز شده را در اختیار شما قرار می دهد و تعداد این فایلها را تا 9 می توان افزایش داد برای تغییر آن می توانید به این منو بروید.

Customize >Preference>File- Recent Files in File menu

فرمان Save

برای ذخیره سازی یک صحنه از این فرمان استفاده می شود که معادل کلیدهای میان بر Ctrl +S است. در نرم‌افزار تری‌دی مکس قابلیتی وجود دارد که فایل ها را می تواند به صورت خودکار در فاصله زمانی معیین ذخیره نماید. این قابلیت را Auto backup می‌گویند و میزان زمان و تعداد ذخیره‌سازی نیز قابل تغییر می باشد.

این فایل‌ها در آدرس نصب شده نرم افزار در پوشه Auto backup قراردارند.

Customize- Preference- Flle- Auto backup

فرمانSave as

به کمک این فرمان می توانید فایلهای Max یا کاراکتر (CHR) را در مکان ها و جاهای متفاوت ذخیره کنید.

فرمانSave Selection :

به کمک این فرمان می توانید اشیاء منتخب در صحنه را ذخیره کنیم البته اشیایی که به صورت سلسله مراتبی هستند به ترتیب سلسله مراتب ذخیره می شوند.

فرمانMerge :

به کمک این فرمان می توانید چند صحنه را ادغام کنید زمان Merge یک سری پیام داده می شود که در زیر توضیح می دهیم.

Merge : شی وارد شده را با استفاده از نام فیلد سمت راست در صحنه جدید ادغام می کند.

Skip : عملیات ادغام شی را لغو می کند.

Delete old : شی موجود در صحنه را از بین برده و شی جدید را که هم نام شی قبلی بوده را جایگزین می کند.

Apply to all duplicate : همه اشیاء وارد شده را به صورتی وارد صحنه می کند که نام اشیاء به صورت (تکثیر) تغییر نام پیدا کنند.

Cancel : عملیات ادغام را لغو می کند.

Rename merged material :اسامی مواد وارد شده به صحنه را می توان تغییر داد.

Use scene material : خصوصیات مواد موجود در صحنه را بر مواد وارد شده می دهد.

Use merged material :مواد وارد شده به صحنه را به اشیا می دهد.

Auto Rename merged material : به صورت خودکار مواد وارد شده به صحنه را تغییر نام می دهد.

Apply To Duplicates :همه مواد را به صورتی وارد می کند که نام آنها به صورت (تکثیر) تغییر نام پیدا می کند.

Export :

به کمک این فرمان می توانید فایلهای MAX را به صورت فایلهای دیگر خروجی بگیرید فرمت های خروجی به شرح زیر است. 3D Studio (3DS) Adobe illustrator (Ai) ASC scene Export (ASE) Auto CAD (DWG) Auto CAD (DXF) Shockwave 3D Film Box (FBX) Initial Graphics Exchange Standard (IGES) Lights cape material (ATR) Lights cape Blocks (BLK) Lights cape Parameter (DF) Lights cape Layers (LAY) Lights cape View (VW) Lights cape Preparation Flle (LP) Stereo lithography (STL) VRML 97 (WRL)

فرمان Import :

توسط این فرمان می توانید فایل هایی که از نوعMAX نیست را به داخل نرم افزار وارد نمود.

فرمانMerge Animation

توسط این فرمان می توان اطلاعات متحرک سازی شی دیگر یا صحنه را به شی یا صحنه ای وارد و منتقل کنید.

فرمان Replace :

توسط این فرمان قادر خواهید بود که شی یا شکل هندسی ساده تری جایگزین یک شی پیچیده تر در صحنه نموده و پس از انجام عملیات( متحرک سازی و امثال آن) دوباره شی یا شکل هندسی را جایگزین کنید.

فرمانExport selected :

به کمک این فرمان می توانید شی یا اشیاء انتخابی را خروجی بگیرید.

فرمان Summary Info

این فرمان قادر است اطلاعات آماری مربوط به صحنه جاری را در اختیار شما قرار می دهد.

فرمان Flle Properties

به کمک این فرمان می توانید خصوصیات فایل جاری را مشاهده کنید و در این پنجره می توانید اطلاعاتی جانبی را که مربوط به فایل هست به آن اضافه کنید.

فرمان View Image Flle :

به کمک این فرمان می توانید تصاویر ساکن موجود را مشاهده کنید در واقع آن یک برنامه کمکی برای مشاهده عکس است.

منوی Edit[ویرایش]

این منو شامل فرمانهایی برای انتخاب و ویرایش اشیاء صحنه است این فرمان‌ها به قرار زیر می‌باشند.

فرمان Undo

آخرین عملیات انجام شده توسط شما را معکوس می‌کند و برمی گرداند و معادل کلیدهای میان بر Ctrl +z است.

فرمان Redo

این فرمان آخرین عملیات لغو شده توسط فرمان Undo را برمی گرداند و معادل کلیدهای میان بر Ctrl+y است برای افزایش تعداد Redo و Undo می‌توان از منوی

Customize = Preferences = Gene yal= Scan Undo

استفاده نمود.

همچنین می‌توانید از کلیدهای Undo و Redo در نوار ابزار استفاده نموده و اگر هم بر روی این کلیدها راست کلیک کنید لیستی از عملیاتی که تا به حال انجام شده را در اختیار شما قرار می‌دهد.

فرمان Hold

هرگاه می‌خواهید عملیاتی را انجام دهید که این عملیات برای شما ناشناخته است امکان از بین رفتن و تبدیل کردن شیی به شیی دیگر را دارید و امکان undo هم نیست (undo در همه موارد کار نمی‌کند) استفاده کنید. این فرمان یک فایل موقتی (max hold. my) را ایجاد می‌کند. این فایل بر روی کلیپ برد یا حافظ موقت ذخیره می‌شود و با بشته شدن یا خاموش شدن ناگهانی از بین می‌رود.

برای بازیابی این فایل باید از فرمان Fetch استفاده نمود.

فرمان Fetch محتوی بافر Hold شامل صحنه ذخیره شده و تنظیمات سیستم را حفظ می‌کند.

فرمان Delete

به کمک این فرمان می‌توانید اشیا داخل صحنه را از بین ببرید و حذف نمایید البته اشیاء حذف شده قابل برگشت (undo) هستند.

فرمان Clone

به کمک این فرمان می‌توانید یک کپی از اشیاء یا شی‌های موجود در صحنه بگیریم که کلید میان بر آن معادل Ctrl +V می‌باشد.

فرمان Select All

به کمک این فرمان تمامی اشیاء در صحنه را انتخاب می‌نماید که کلید میان بر آن معادل Ctrl +A می‌باشد.

فرمان Select invert

این فرمان عملیات انتخاب را معکوس می‌کند که کلید میان بر آن معادل Ctrl +I می‌باشد.

گزینه Object Propertise

این گزینه یک سری اطلاعات و قابلیت‌ها را در اختیار ما قرار می‌دهد که در آموزش‌های بعد مفصل به آن می‌پردازیم.

منوی Group[ویرایش]

این منو و فرمان‌های داخل آن برای دسته‌بندی و اجتماع دادن چند شی در صحنه مورد استفاده قرار می‌گیرد.

فرمان Group

به کمک این فرمان شی‌های انتخاب شده در صحنه را به صورت یک گروه در می‌آوریم به این صورت که زمانی که یک شکل انتخاب می‌شود تمام اشکالی که با آن شکل تشکیل گروه را داده‌اند انتخاب می‌شوند.

فرمان Group un

این فرمان باعث از بین رفتن و متلاشی شدن یک گروه می‌شود.

فرمان open

این فرمان باعث می‌شود که یک گروه به صورت موقت باز شده و اشیاء موجود در گروه قابل ویرایش شوند ولی گروه هنوز از بین نرفته و نرم‌افزار برای ثابت کردن این مطلب معمولاً یک کادر مکعب در دور گروه باز شده می‌کشد که این اشیاء گروهی هستند که به صورت موقت باز شده است.

فرمان Close

این فرمان باعث بسته شدن گروهی می‌شود که آن گروه باز شده باشد.

فرمان Attach

به کمک این فرمان می‌توان اشیاء که در گروهی وجود ندارند را به یک گروه اضافه نمود. به این صورت که روی آن شی که در گروهی نیست کلیک کرده و سپس از منوی Group گزینه Attach را زده تا آن شی به آن گروه اضافه شود.

فرمان Detach

به کمک این فرمان می‌توان اشیاء که در درون یک گروه هستند را از آن گروه جدا نمود این فرمان زمانی روشن است که قبل از آن گزینه یا فرمان open را به کار برده باشیم.

فرمان Explode

این فرمان می‌تواند گروههای انتخابی را کاملاً متلاشی کند؛ و باعث متلاشی شدن گروه‌های انتخابی می‌شد و تفاوت این فرمان با فرمان Group un این است که فرمان Group un فقط یک گروه را از بین ولی فرمان Explode به جز از بین بردن گروهی اصلی گروه‌های فرعی را نیز از بین می‌برد.

فرمان Assemble

این فرمان مجموعه‌ای از اشیا منتخب یا اسمبل‌ها یا گروه‌ها را در یک اسمبل قرار داده و یک شی کمکی Liumihaire را به عنوان شی رییس (head object) ایجاد می‌کند هنگامی که فرمان اسمبل را اجرا می‌کنید می‌توانید اشیا اسمبل شده را به عنوان یک شی واحد و مستقل در صحنه در نظر بگیرید. برای انتخاب کل اسمبل می‌توانید بر روی هر یک از اشیا عضو آن کلیک کنید داخل هر اسمبل می‌تواند گروه‌ها و اسمبل‌ها دیگر را قرار داد.

در هر اسمبل موقعیت و گرایش شی رییس (head) به شرح زیر تعیین می‌شود.

اگر فرزندهای بدون واسطه برای شی رییس وجود داشته باشند آنگاه شی رییس با مرکز پایین جعبه محیطی اسمبل تراز می‌شود.

اگر فقط یک فرزند بدون واسطه برای شی رییس وجود داشته باشد آنگاه نقطه اتکای این شی با نقطه اتکای شی فرزند تراز خواهد شد.

فرمان این قسمت مانند فرمان‌ها قسمت Group می‌باشد.